aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mkimage
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-09-23 08:49:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-09-23 08:49:34 +0000
commitcaefc9ac53ed5d3557faf0ff9cbcea71577d1733 (patch)
treefc8538ecc2cc0a5669e44ae1a25ceb2a11f2f554 /tools/mkimage
parentec4446db903c854a5d0cf7cb4487ce4a9297fa39 (diff)
downloadmaster-187ad058-caefc9ac53ed5d3557faf0ff9cbcea71577d1733.tar.gz
master-187ad058-caefc9ac53ed5d3557faf0ff9cbcea71577d1733.tar.bz2
master-187ad058-caefc9ac53ed5d3557faf0ff9cbcea71577d1733.zip
tools/mkimage: avoid picking up unrelated /usr/include headers with the same name as internal header files (e.g. image.h), fixes #12232
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33519 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/mkimage')
-rw-r--r--tools/mkimage/Makefile7
-rw-r--r--tools/mkimage/patches/040-include_order.patch14
2 files changed, 21 insertions, 0 deletions
diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index 373d9bebb8..149aaa6f12 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -18,6 +18,13 @@ HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
include $(INCLUDE_DIR)/host-build.mk
+define Host/Prepare
+ $(Host/Prepare/Default)
+ rm -f \
+ $(HOST_BUILD_DIR)/include/errno.h \
+ $(HOST_BUILD_DIR)/include/malloc.h
+endef
+
define Host/Compile
rm -f $(HOST_BUILD_DIR)/tools/.depend
touch $(HOST_BUILD_DIR)/include/config.h
diff --git a/tools/mkimage/patches/040-include_order.patch b/tools/mkimage/patches/040-include_order.patch
new file mode 100644
index 0000000000..5a9d15eb76
--- /dev/null
+++ b/tools/mkimage/patches/040-include_order.patch
@@ -0,0 +1,14 @@
+--- a/tools/Makefile
++++ b/tools/Makefile
+@@ -159,9 +159,9 @@ NOPEDOBJS := $(addprefix $(obj),$(NOPED_
+ # Use native tools and options
+ # Define __KERNEL_STRICT_NAMES to prevent typedef overlaps
+ #
+-HOSTCPPFLAGS = -idirafter $(SRCTREE)/include \
++HOSTCPPFLAGS = -I $(SRCTREE)/include \
+ -idirafter $(OBJTREE)/include2 \
+- -idirafter $(OBJTREE)/include \
++ -I $(OBJTREE)/include \
+ -I $(SRCTREE)/lib/libfdt \
+ -I $(SRCTREE)/tools \
+ -DCONFIG_SYS_TEXT_BASE=$(CONFIG_SYS_TEXT_BASE) \