aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mkimage
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-07-19 14:59:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-07-19 14:59:26 +0000
commit65b6f3472d61313df9f81005a8ef52f753a352b4 (patch)
treee81567eabb2520496253866b4f73104484d36fb4 /tools/mkimage
parentf4ed380cf7c82ca040b94d19a63efbc621056233 (diff)
downloadmaster-187ad058-65b6f3472d61313df9f81005a8ef52f753a352b4.tar.gz
master-187ad058-65b6f3472d61313df9f81005a8ef52f753a352b4.tar.bz2
master-187ad058-65b6f3472d61313df9f81005a8ef52f753a352b4.zip
mkimage: cross compile fix: pass HOST_*FLAGS in to uboot's makefile
The HOST_*FLAGS are for compiling programs which will run on the machine that is running the build. Setting these flags is frequently required for unusual cross-compiles. Signed-off-by: Lawrence D'Anna <larry@elder-gods.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46424 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/mkimage')
-rw-r--r--tools/mkimage/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index a65eedfcc6..f73cc56318 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -31,8 +31,8 @@ define Host/Prepare
endef
define Host/Compile
- $(MAKE) -C $(HOST_BUILD_DIR) defconfig
- $(MAKE) -C $(HOST_BUILD_DIR) tools-only
+ $(MAKE) -C $(HOST_BUILD_DIR) defconfig HOSTCFLAGS="$(HOST_CPPFLAGS) $(HOST_CFLAGS)" HOSTLDFLAGS="$(HOST_LDFLAGS)"
+ $(MAKE) -C $(HOST_BUILD_DIR) tools-only HOSTCFLAGS="$(HOST_CPPFLAGS) $(HOST_CFLAGS)" HOSTLDFLAGS="$(HOST_LDFLAGS)"
endef
define Host/Install