aboutsummaryrefslogtreecommitdiffstats
path: root/tools/m4
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-09-24 20:01:00 +0000
committerLuka Perkov <luka@openwrt.org>2013-09-24 20:01:00 +0000
commitfc411421f32f78e0266e016b3a056e3bf5971303 (patch)
tree3869273670847d1aa8ce7581b7c4a92c9745f3e3 /tools/m4
parent0a3142244fa33c0f14f657a7ec80e1f583f22e51 (diff)
downloadmaster-187ad058-fc411421f32f78e0266e016b3a056e3bf5971303.tar.gz
master-187ad058-fc411421f32f78e0266e016b3a056e3bf5971303.tar.bz2
master-187ad058-fc411421f32f78e0266e016b3a056e3bf5971303.zip
[tools] m4: update to 1.4.17
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38168 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/m4')
-rw-r--r--tools/m4/Makefile10
-rw-r--r--tools/m4/patches/100-fix-gets-removal.patch16
2 files changed, 14 insertions, 12 deletions
diff --git a/tools/m4/Makefile b/tools/m4/Makefile
index 080eb5d99c..71498b490a 100644
--- a/tools/m4/Makefile
+++ b/tools/m4/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2008-2012 OpenWrt.org
+# Copyright (C) 2008-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -7,12 +7,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=m4
-PKG_VERSION:=1.4.16
+PKG_VERSION:=1.4.17
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
-PKG_MD5SUM:=a5dfb4f2b7370e9d34293d23fd09b280
-PKG_CAT:=zcat
+PKG_MD5SUM:=12a3c829301a4fd6586a57d3fcf196dc
+PKG_CAT:=xzcat
HOST_BUILD_PARALLEL:=1
diff --git a/tools/m4/patches/100-fix-gets-removal.patch b/tools/m4/patches/100-fix-gets-removal.patch
index be0ea851ce..ecd110d934 100644
--- a/tools/m4/patches/100-fix-gets-removal.patch
+++ b/tools/m4/patches/100-fix-gets-removal.patch
@@ -1,15 +1,17 @@
--- a/lib/stdio.in.h
+++ b/lib/stdio.in.h
-@@ -158,12 +158,6 @@ _GL_WARN_ON_USE (fflush, "fflush is not
- "use gnulib module fflush for portable POSIX compliance");
+@@ -714,14 +714,6 @@ _GL_WARN_ON_USE (getline, "getline is un
+ # endif
#endif
-/* It is very rare that the developer ever has full control of stdin,
-- so any use of gets warrants an unconditional warning. Assume it is
-- always declared, since it is required by C89. */
+- so any use of gets warrants an unconditional warning; besides, C11
+- removed it. */
-#undef gets
+-#if HAVE_RAW_DECL_GETS
-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+-#endif
-
- #if @GNULIB_FOPEN@
- # if @REPLACE_FOPEN@
- # if !(defined __cplusplus && defined GNULIB_NAMESPACE)
+
+ #if @GNULIB_OBSTACK_PRINTF@ || @GNULIB_OBSTACK_PRINTF_POSIX@
+ struct obstack;