aboutsummaryrefslogtreecommitdiffstats
path: root/tools/lzma
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-10 19:26:30 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-10 19:26:30 +0000
commit5ca993f88d7303a84be602c80760fc02770b7be8 (patch)
tree5b2f3714c3ef2d226a39b838bb651ddff2fdbed0 /tools/lzma
parent739b17763770fc90d35445476733c845d4730c2d (diff)
downloadmaster-187ad058-5ca993f88d7303a84be602c80760fc02770b7be8.tar.gz
master-187ad058-5ca993f88d7303a84be602c80760fc02770b7be8.tar.bz2
master-187ad058-5ca993f88d7303a84be602c80760fc02770b7be8.zip
[tools] lzma: link statically
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33094 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/lzma')
-rw-r--r--tools/lzma/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/lzma/Makefile b/tools/lzma/Makefile
index 4922f8087f..00ed3dc425 100644
--- a/tools/lzma/Makefile
+++ b/tools/lzma/Makefile
@@ -21,8 +21,8 @@ UTIL_DIR=$(HOST_BUILD_DIR)/C/LzmaUtil
ALONE_DIR=$(HOST_BUILD_DIR)/CPP/7zip/Compress/LZMA_Alone
define Host/Compile
- $(MAKE) -C $(UTIL_DIR) -f makefile.gcc
- $(MAKE) -C $(ALONE_DIR) -f makefile.gcc
+ $(MAKE) -C $(UTIL_DIR) -f makefile.gcc LDFLAGS="-static"
+ $(MAKE) -C $(ALONE_DIR) -f makefile.gcc LDFLAGS="-static"
endef
define Host/Install