aboutsummaryrefslogtreecommitdiffstats
path: root/tools/lzma
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-12 13:27:49 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-12 13:27:49 +0000
commit3cd5af40b38be1ee1a78b74c4177efc58f68d316 (patch)
tree55ac753baef40f1b56d061cdbb5ea4d185647da4 /tools/lzma
parentb35dab3480040f1b3da61838ada54ff496c649b5 (diff)
downloadmaster-187ad058-3cd5af40b38be1ee1a78b74c4177efc58f68d316.tar.gz
master-187ad058-3cd5af40b38be1ee1a78b74c4177efc58f68d316.tar.bz2
master-187ad058-3cd5af40b38be1ee1a78b74c4177efc58f68d316.zip
[tools] convert remaining tools to $(HOST_STATIC_LINKING) (#12012)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33148 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/lzma')
-rw-r--r--tools/lzma/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/lzma/Makefile b/tools/lzma/Makefile
index 00ed3dc425..6e01051a3a 100644
--- a/tools/lzma/Makefile
+++ b/tools/lzma/Makefile
@@ -21,8 +21,8 @@ UTIL_DIR=$(HOST_BUILD_DIR)/C/LzmaUtil
ALONE_DIR=$(HOST_BUILD_DIR)/CPP/7zip/Compress/LZMA_Alone
define Host/Compile
- $(MAKE) -C $(UTIL_DIR) -f makefile.gcc LDFLAGS="-static"
- $(MAKE) -C $(ALONE_DIR) -f makefile.gcc LDFLAGS="-static"
+ $(MAKE) -C $(UTIL_DIR) -f makefile.gcc LDFLAGS="$(HOST_STATIC_LINKING)"
+ $(MAKE) -C $(ALONE_DIR) -f makefile.gcc LDFLAGS="$(HOST_STATIC_LINKING)"
endef
define Host/Install