aboutsummaryrefslogtreecommitdiffstats
path: root/tools/lzma/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-05-17 00:57:47 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-05-17 00:57:47 +0000
commitefa8655f20c29df2755e4e01520e3c86a450c28c (patch)
treea2a8ff7b24fff058e0cbc01cba6920d967b1dfc7 /tools/lzma/Makefile
parente3667594fb5a8ef407e756a335961caf4196d278 (diff)
downloadmaster-187ad058-efa8655f20c29df2755e4e01520e3c86a450c28c.tar.gz
master-187ad058-efa8655f20c29df2755e4e01520e3c86a450c28c.tar.bz2
master-187ad058-efa8655f20c29df2755e4e01520e3c86a450c28c.zip
add the new lzma library (version 4.65), to be used for squashfs4
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15883 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/lzma/Makefile')
-rw-r--r--tools/lzma/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/tools/lzma/Makefile b/tools/lzma/Makefile
new file mode 100644
index 0000000000..18fe030886
--- /dev/null
+++ b/tools/lzma/Makefile
@@ -0,0 +1,35 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lzma
+PKG_VERSION:=4.65
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
+PKG_MD5SUM:=434e51a018b4c8ef377bf81520a53af0
+
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+UTIL_DIR=$(HOST_BUILD_DIR)/C/LzmaUtil
+
+define Host/Compile
+ $(MAKE) -C $(UTIL_DIR) -f makefile.gcc
+endef
+
+define Host/Install
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/lib $(STAGING_DIR_HOST)/include
+ $(CP) $(HOST_BUILD_DIR)/C/*.h $(STAGING_DIR_HOST)/include/
+ $(CP) $(UTIL_DIR)/liblzma.a $(STAGING_DIR_HOST)/lib/
+endef
+
+define Host/Clean
+endef
+
+$(eval $(call HostBuild))