aboutsummaryrefslogtreecommitdiffstats
path: root/tools/lzma/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-05-04 17:04:03 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-05-04 17:04:03 +0000
commit5d2d7cfd8f9a1c9cb0234590e305b6b4c0ec8d59 (patch)
tree451936aeb32c90543e334fe56019d8c04a5d380c /tools/lzma/Makefile
parent7d4ffdc4287a78251d258cc88557bfda390fbcc9 (diff)
downloadmaster-187ad058-5d2d7cfd8f9a1c9cb0234590e305b6b4c0ec8d59.tar.gz
master-187ad058-5d2d7cfd8f9a1c9cb0234590e305b6b4c0ec8d59.tar.bz2
master-187ad058-5d2d7cfd8f9a1c9cb0234590e305b6b4c0ec8d59.zip
rename tools/lzma to tools/lzma-old (preparation for adding a new lzma version)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15595 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/lzma/Makefile')
-rw-r--r--tools/lzma/Makefile39
1 files changed, 0 insertions, 39 deletions
diff --git a/tools/lzma/Makefile b/tools/lzma/Makefile
deleted file mode 100644
index b982415c5a..0000000000
--- a/tools/lzma/Makefile
+++ /dev/null
@@ -1,39 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=lzma
-PKG_VERSION:=4.32
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
-PKG_MD5SUM:=5587d6ac230ad1903d504fc3253f0e42
-
-HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/host-build.mk
-
-LIB_DIR=$(HOST_BUILD_DIR)/C/7zip/Compress/LZMA_Lib
-ALONE_DIR=$(HOST_BUILD_DIR)/C/7zip/Compress/LZMA_Alone
-
-define Host/Compile
- $(MAKE) -C $(LIB_DIR)
- $(MAKE) -f makefile.gcc -C $(ALONE_DIR)
-endef
-
-define Host/Install
- $(INSTALL_DATA) $(LIB_DIR)/liblzma.a $(STAGING_DIR_HOST)/lib/
- $(INSTALL_BIN) $(ALONE_DIR)/lzma $(STAGING_DIR_HOST)/bin/
-endef
-
-define Host/Clean
- rm -f \
- $(STAGING_DIR_HOST)/lib/liblzma.a \
- $(STAGING_DIR_HOST)/bin/lzma
-endef
-
-$(eval $(call HostBuild))