aboutsummaryrefslogtreecommitdiffstats
path: root/tools/libelf
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-06-03 00:44:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-06-03 00:44:49 +0000
commitb7fae73a932b89c309315c0bfeb6b787e8eea4e6 (patch)
tree10aa9ecb22fde1a24991d57005f07a5e27cf92b0 /tools/libelf
parent87df934c7c6f611b668a61465b82879fd7747792 (diff)
downloadmaster-187ad058-b7fae73a932b89c309315c0bfeb6b787e8eea4e6.tar.gz
master-187ad058-b7fae73a932b89c309315c0bfeb6b787e8eea4e6.tar.bz2
master-187ad058-b7fae73a932b89c309315c0bfeb6b787e8eea4e6.zip
libelf: get rid of CRLF encoding in the makefile (thx, danimo)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21663 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/libelf')
-rw-r--r--tools/libelf/Makefile98
1 files changed, 49 insertions, 49 deletions
diff --git a/tools/libelf/Makefile b/tools/libelf/Makefile
index 00d424f3fd..f38d70d09b 100644
--- a/tools/libelf/Makefile
+++ b/tools/libelf/Makefile
@@ -1,49 +1,49 @@
-#
-# Copyright (C) 2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libelf
-PKG_VERSION:=0.8.13
-PKG_MD5SUM:=4136d7b4c04df68b686570afa26988ac
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.mr511.de/software/
-
-include $(INCLUDE_DIR)/host-build.mk
-
-HOST_CONFIGURE_ARGS += \
- --disable-shared \
- --enable-elf64
-
-define Host/Configure
- (cd $(HOST_BUILD_DIR)/$(3); \
- $(HOST_CONFIGURE_CMD) \
- $(HOST_CONFIGURE_ARGS); \
- )
-endef
-
-
-define Host/Compile
- $(MAKE) -C $(HOST_BUILD_DIR)/lib/ libelf.a
-endef
-
-define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/{lib,include/libelf}
- $(CP) $(HOST_BUILD_DIR)/lib/{elf_repl.h,gelf.h,libelf.h,nlist.h,sys_elf.h} \
- $(STAGING_DIR_HOST)/include/libelf/
- $(CP) $(HOST_BUILD_DIR)/lib/libelf.a $(STAGING_DIR_HOST)/lib/
-endef
-
-define Host/Clean
- rm -rf $(STAGING_DIR_HOST)/include/libelf
- rm -f $(STAGING_DIR_HOST)/lib/libelf.a
- $(call Host/Clean/Default)
-endef
-
-$(eval $(call HostBuild))
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libelf
+PKG_VERSION:=0.8.13
+PKG_MD5SUM:=4136d7b4c04df68b686570afa26988ac
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.mr511.de/software/
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CONFIGURE_ARGS += \
+ --disable-shared \
+ --enable-elf64
+
+define Host/Configure
+ (cd $(HOST_BUILD_DIR)/$(3); \
+ $(HOST_CONFIGURE_CMD) \
+ $(HOST_CONFIGURE_ARGS); \
+ )
+endef
+
+
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR)/lib/ libelf.a
+endef
+
+define Host/Install
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/{lib,include/libelf}
+ $(CP) $(HOST_BUILD_DIR)/lib/{elf_repl.h,gelf.h,libelf.h,nlist.h,sys_elf.h} \
+ $(STAGING_DIR_HOST)/include/libelf/
+ $(CP) $(HOST_BUILD_DIR)/lib/libelf.a $(STAGING_DIR_HOST)/lib/
+endef
+
+define Host/Clean
+ rm -rf $(STAGING_DIR_HOST)/include/libelf
+ rm -f $(STAGING_DIR_HOST)/lib/libelf.a
+ $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))