aboutsummaryrefslogtreecommitdiffstats
path: root/tools/libelf
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-09-15 14:17:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-09-15 14:17:58 +0000
commit4d0a4147cf2688229c4d9d04325202b9e35d07c8 (patch)
tree8ba21edf948d61b4d85f325dd8140c4272a87e2d /tools/libelf
parent0c41980d7788e9723fc59832107379b64d1c13e8 (diff)
downloadmaster-187ad058-4d0a4147cf2688229c4d9d04325202b9e35d07c8.tar.gz
master-187ad058-4d0a4147cf2688229c4d9d04325202b9e35d07c8.tar.bz2
master-187ad058-4d0a4147cf2688229c4d9d04325202b9e35d07c8.zip
tools/libelf: enable parallel builds
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33437 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/libelf')
-rw-r--r--tools/libelf/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/tools/libelf/Makefile b/tools/libelf/Makefile
index f38d70d09b..dbd6eed89a 100644
--- a/tools/libelf/Makefile
+++ b/tools/libelf/Makefile
@@ -15,6 +15,8 @@ PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.mr511.de/software/
+HOST_BUILD_PARALLEL:=1
+
include $(INCLUDE_DIR)/host-build.mk
HOST_CONFIGURE_ARGS += \
@@ -30,7 +32,7 @@ endef
define Host/Compile
- $(MAKE) -C $(HOST_BUILD_DIR)/lib/ libelf.a
+ $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR)/lib/ libelf.a
endef
define Host/Install