aboutsummaryrefslogtreecommitdiffstats
path: root/tools/gmp
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-22 04:37:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-22 04:37:20 +0000
commitb892e1fb855de59ce8e81881526ede35df1ae3fd (patch)
tree8497134d453d336d68b5dbf67d9b6b719ed2145e /tools/gmp
parent67c9c212e61d7ce11aa22e3ac5f7a109c134c0d1 (diff)
downloadmaster-187ad058-b892e1fb855de59ce8e81881526ede35df1ae3fd.tar.gz
master-187ad058-b892e1fb855de59ce8e81881526ede35df1ae3fd.tar.bz2
master-187ad058-b892e1fb855de59ce8e81881526ede35df1ae3fd.zip
build system refactoring in preparation for allowing packages to do host-build steps
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14610 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/gmp')
-rw-r--r--tools/gmp/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/tools/gmp/Makefile b/tools/gmp/Makefile
index 42646716b5..4c6fac425f 100644
--- a/tools/gmp/Makefile
+++ b/tools/gmp/Makefile
@@ -15,8 +15,8 @@ PKG_MD5SUM:=
include $(INCLUDE_DIR)/host-build.mk
-define Build/Configure
- (cd $(PKG_BUILD_DIR); \
+define Host/Configure
+ (cd $(HOST_BUILD_DIR); \
./configure \
--prefix=$(STAGING_DIR_HOST) \
--build=$(GNU_HOST_NAME) \
@@ -27,16 +27,16 @@ define Build/Configure
);
endef
-define Build/Compile
- make -C $(PKG_BUILD_DIR) all
+define Host/Compile
+ make -C $(HOST_BUILD_DIR) all
endef
-define Build/Install
- make -C $(PKG_BUILD_DIR) install
+define Host/Install
+ make -C $(HOST_BUILD_DIR) install
endef
-define Build/Clean
- rm -rf $(PKG_BUILD_DIR)
+define Host/Clean
+ rm -rf $(HOST_BUILD_DIR)
endef
$(eval $(call HostBuild))