aboutsummaryrefslogtreecommitdiffstats
path: root/tools/gmp
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-25 16:57:16 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-25 16:57:16 +0000
commit02bd4afb8c33c7ff04fed3f803ed3a2f9a26e8d7 (patch)
tree9024c9345202f344a1c9186676d8c5e6226a8fec /tools/gmp
parent7d5e12fd4d09de4c3929505bf6d03f0b8f1ab625 (diff)
downloadmaster-187ad058-02bd4afb8c33c7ff04fed3f803ed3a2f9a26e8d7.tar.gz
master-187ad058-02bd4afb8c33c7ff04fed3f803ed3a2f9a26e8d7.tar.bz2
master-187ad058-02bd4afb8c33c7ff04fed3f803ed3a2f9a26e8d7.zip
tools: Fix compilation on x32 host
Compiling the host tools on the new x32 architecture (which is an ILP32 ELF32 system on an amd64 CPU) fails for various reasons. gmp: pull same fix I applied to OpenADK, which was inspired by the fix in the Debian source package mtd-utils: write a workaround myself; only affects x32, but the use of llseek is dangerous according to the manpage, so the guard ifdef should probably go away findutils: pull fix straight from the Debian source packae Signed-off-by: Thorsten Glaser <tg@mirbsd.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43060 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/gmp')
-rw-r--r--tools/gmp/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/gmp/Makefile b/tools/gmp/Makefile
index 463cbe9f5c..b1976d0cc3 100644
--- a/tools/gmp/Makefile
+++ b/tools/gmp/Makefile
@@ -27,4 +27,8 @@ HOST_CONFIGURE_ARGS += \
--enable-cxx \
--enable-mpbsd
+ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
+HOST_CONFIGURE_ARGS += ABI=x32
+endif
+
$(eval $(call HostBuild))