aboutsummaryrefslogtreecommitdiffstats
path: root/tools/flex
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-03-12 10:47:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-03-12 10:47:31 +0000
commit2a6e868a2a9b8dfbb1fd2e31bea5a7bd81927fd4 (patch)
tree55bd20936cd85c8ed13cfd2940498f513e530e1a /tools/flex
parent18e83ff89af4c9841689d195c467dc4f8ce47783 (diff)
downloadmaster-187ad058-2a6e868a2a9b8dfbb1fd2e31bea5a7bd81927fd4.tar.gz
master-187ad058-2a6e868a2a9b8dfbb1fd2e31bea5a7bd81927fd4.tar.bz2
master-187ad058-2a6e868a2a9b8dfbb1fd2e31bea5a7bd81927fd4.zip
flex: fix build error due to undefined library symbols
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39888 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/flex')
-rw-r--r--tools/flex/patches/100-remove_no_undefined.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/tools/flex/patches/100-remove_no_undefined.patch b/tools/flex/patches/100-remove_no_undefined.patch
new file mode 100644
index 0000000000..4e8aca13c7
--- /dev/null
+++ b/tools/flex/patches/100-remove_no_undefined.patch
@@ -0,0 +1,18 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -73,13 +73,13 @@ libfl_la_SOURCES = \
+ libmain.c \
+ libyywrap.c
+
+-libfl_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
++libfl_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
+
+ libfl_pic_la_SOURCES = \
+ libmain.c \
+ libyywrap.c
+
+-libfl_pic_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
++libfl_pic_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
+
+ noinst_HEADERS = \
+ flexdef.h \