aboutsummaryrefslogtreecommitdiffstats
path: root/tools/firmware-utils/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-02-14 17:48:04 +0000
committerJohn Crispin <blogic@openwrt.org>2012-02-14 17:48:04 +0000
commitf7b9691687050c32e7bb25a4655d4850630ef7df (patch)
tree99f52b7f4e0ef57fdafe33f296ef62795f501987 /tools/firmware-utils/Makefile
parentb90d992cc7f30e7dac8e2a6221ccc2a7c63174cb (diff)
downloadmaster-187ad058-f7b9691687050c32e7bb25a4655d4850630ef7df.tar.gz
master-187ad058-f7b9691687050c32e7bb25a4655d4850630ef7df.tar.bz2
master-187ad058-f7b9691687050c32e7bb25a4655d4850630ef7df.zip
[lantiq] Support booting the Speedport W502V using BRN-BOOT.
While the disadvantage is less available flash space, it's easy and safe to flash without opening the device. Going back to the original firmware is also possible. This patch add two firmware utilities, mkbrncmdline and mkbrnboot. mkbrncmdline patches the uncompressed kernel so the registeres a0 to a3 are initialized and the memory size is passed in. mkbrnboot takes the lzma compressed kernel and squashfs images and creates a firmware image that can be flashed using the BRN-BOOT recovery kernel, which is booted by holding both buttons when powering up the device and will listen on http://192.168.2.1. The firmware file from bin/lantiq/ to use is openwrt-lantiq-danube-ARV4525PW-BRNDTW502-brnImage The BRN-BOOT recovery kernel does size-check the image, so if it's too big to fit into flash it will complain accordingly. A second patch is needed to make the wired network interface work since there is no u-boot to pre-initialise it. Signed-off-by: Tobias Diedrich <ranma+openwrt@tdiedrich.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30532 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/firmware-utils/Makefile')
-rw-r--r--tools/firmware-utils/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index cd7531f216..4364223546 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -55,6 +55,8 @@ define Host/Compile
$(call cc,buffalo-tftp buffalo-lib, -Wall)
$(call cc,mkwrgimg md5, -Wall)
$(call cc,mkedimaximg)
+ $(call cc,mkbrncmdline)
+ $(call cc,mkbrnimg)
endef
define Host/Install