aboutsummaryrefslogtreecommitdiffstats
path: root/tools/firmware-utils/Makefile
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2016-02-01 12:42:00 +0000
committerRafał Miłecki <zajec5@gmail.com>2016-02-01 12:42:00 +0000
commitd69ec7fafced527fc643d01226fba91f4acf3220 (patch)
tree782d4368d01e7c059effddd6a22fc54a592c1c13 /tools/firmware-utils/Makefile
parent9cde66b8221841d62c7ad5901af9d2bed81d9e75 (diff)
downloadmaster-187ad058-d69ec7fafced527fc643d01226fba91f4acf3220.tar.gz
master-187ad058-d69ec7fafced527fc643d01226fba91f4acf3220.tar.bz2
master-187ad058-d69ec7fafced527fc643d01226fba91f4acf3220.zip
firmware-utils: add oseama tool for creating Seama entities
It has an important feature (compared to seama) of using multiple input files, aligning them and padding zeroes until reaching a specified absolute offset. This is needed for a proper flash layout on NAND. We want kernel partition to be big enough to handle future updates without a need to resize it and wipe whole "ubi" partition. It's important as we don't want to lose block counters. Signed-off-by: Rafał Miłecki <zajec5@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48601 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/firmware-utils/Makefile')
-rw-r--r--tools/firmware-utils/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index dc922b0360..7a4403cba2 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -64,6 +64,7 @@ define Host/Compile
$(call cc,mkdapimg)
$(call cc, mkcameofw, -Wall)
$(call cc,seama md5)
+ $(call cc,oseama md5, -Wall)
$(call cc,fix-u-media-header cyg_crc32,-Wall)
$(call cc,hcsmakeimage bcmalgo)
$(call cc,mkporayfw, -Wall)