aboutsummaryrefslogtreecommitdiffstats
path: root/tools/firmware-utils/Makefile
diff options
context:
space:
mode:
authorDaniel Dickinson <daniel@cshore.neomailbox.net>2010-11-16 06:46:53 +0000
committerDaniel Dickinson <daniel@cshore.neomailbox.net>2010-11-16 06:46:53 +0000
commitcaefcca898c3b6632b8a60b500d3586102e1085c (patch)
tree8482554dc599aafac91e637587c204e26c99aa3f /tools/firmware-utils/Makefile
parent6b06e64de2f1b0bffef6722bfd01e17e3a5b5464 (diff)
downloadmaster-187ad058-caefcca898c3b6632b8a60b500d3586102e1085c.tar.gz
master-187ad058-caefcca898c3b6632b8a60b500d3586102e1085c.tar.bz2
master-187ad058-caefcca898c3b6632b8a60b500d3586102e1085c.zip
[tools/firmware-utils] imagetag: Significantly updated brcm63xx imagetag writing tool.
* Rewrote commandline parsing code using gengetopt - We now get long options - We have more options including use of the info section for board information (e.g. to add the same boardid but different GPIOs on different routers) * Added back the ability to write stock images (this is useful, for example, when copying the firmware from the in-memory flash, and then being able to create an image that will let you revert to/test stock firmware * Fixed copying of CRCs to use memcpy instead of strncpy (strncpy stops at 0) * Added ability to use all sections of the imagetag, including custom magic signatures (e.g. for the Telsey router I'm adding soon), info sections, and reserved sections * Added putting the router type (as defined in the image generating Makefile) into the info1 section and the filesystem type in the info2 section. This will be used by mtd (when I add the code) to return the name of image used to flash this router. (As requested by Jo, as well as being useful for same boardid different board scenario described above). git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24011 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/firmware-utils/Makefile')
-rw-r--r--tools/firmware-utils/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index ace2aaae24..eb42f630f7 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -15,7 +15,6 @@ define cc
$(CC) $(HOST_CFLAGS) -include endian.h -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
endef
-
define Host/Compile
mkdir -p $(HOST_BUILD_DIR)/bin
$(call cc,addpattern)
@@ -33,7 +32,7 @@ define Host/Compile
$(call cc,mkcasfw)
$(call cc,mkfwimage,-lz)
$(call cc,mkfwimage2,-lz)
- $(call cc,imagetag)
+ $(call cc,imagetag imagetag_cmdline)
$(call cc,add_header)
$(call cc,makeamitbin)
$(call cc,encode_crc)