aboutsummaryrefslogtreecommitdiffstats
path: root/tools/firmware-utils/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-17 15:38:54 +0000
committerJohn Crispin <blogic@openwrt.org>2014-06-17 15:38:54 +0000
commit7911faae005a1945f399da4f92130eea8921f34c (patch)
tree80694efe6ee928359017183e5e75d5ded345497d /tools/firmware-utils/Makefile
parentdfb41660c78c9148b7d4f3b888a56a41c3d760cb (diff)
downloadmaster-187ad058-7911faae005a1945f399da4f92130eea8921f34c.tar.gz
master-187ad058-7911faae005a1945f399da4f92130eea8921f34c.tar.bz2
master-187ad058-7911faae005a1945f399da4f92130eea8921f34c.zip
lantiq: DGN3500 (all known variants) factory and sysupgrade image building support
This patch adds factory image building for the DGN3500, all variants, and fixes sysupgrade images to make them play nice with the sercomm secondary boot loader. The factory images can be used directly in the update dialog in the interface of the stock firmware and via the special Sercomm bootmode and a special windows flashing utility (allegedly present in the CD that came with the device -- but it's also compatible with the NSLU2 Upgrade_207_XP utility.) The special bootmode can be activated by turning the device on while holding the reset button pressed, then releasing it when the power led starts blinking red and green. Please notice that if using the 207 utility, it will always report that the flashing failed even though it completed successfully. Just power cycle the router manually after the utility reports the failure and OpenWRT will boot. This same utility (despite reporting failure in this case too) can revert a DGN3500 (any variant) to the appropriate stock Netgear firmware. This patch is a heavily modified version of a package I found on the OpenWRT forum with a couple fixes and features added -- mainly the generation of all the different image variants to support all known models directly, atm known variants are AnnexA-WW, AnnexA-NA and AnnexB-DE/GR. I tested the patch successfully on my device. Signed-off-by: Marco Antonio Mauro <marcus90@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41236 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/firmware-utils/Makefile')
-rw-r--r--tools/firmware-utils/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index 8f17c3e923..64eccdd226 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -68,6 +68,7 @@ define Host/Compile
$(call cc,mkdcs932, -Wall)
$(call cc,mkheader_gemtek,-lz)
$(call cc,mkrtn56uimg, -lz)
+ $(call cc,dgn3500sum)
endef
define Host/Install