aboutsummaryrefslogtreecommitdiffstats
path: root/tools/dosfstools
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-07-24 20:39:00 +0000
committerJohn Crispin <blogic@openwrt.org>2012-07-24 20:39:00 +0000
commit68ca3cdc277f72f5f3ee99dd63fba93f8268f6fc (patch)
treef9c13b798989aa3546db1945d5086efbd9e3d0cb /tools/dosfstools
parent868ad2121ef5f87377e3612e6012b433b5306530 (diff)
downloadmaster-187ad058-68ca3cdc277f72f5f3ee99dd63fba93f8268f6fc.tar.gz
master-187ad058-68ca3cdc277f72f5f3ee99dd63fba93f8268f6fc.tar.bz2
master-187ad058-68ca3cdc277f72f5f3ee99dd63fba93f8268f6fc.zip
[tools] add mktools and dosfstools which are needed for the raspberry pi
Signed-off-by: Ian Ridge <ianridge [at] gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32824 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/dosfstools')
-rw-r--r--tools/dosfstools/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/tools/dosfstools/Makefile b/tools/dosfstools/Makefile
new file mode 100644
index 0000000000..88ac057f16
--- /dev/null
+++ b/tools/dosfstools/Makefile
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=dosfstools
+PKG_VERSION:=3.0.7
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
+PKG_SOURCE_URL:=http://dosfstools.sourcearchive.com/downloads/3.0.7/
+PKG_MD5SUM:=5d4d97c79e8dae60bb08c2fba36c94d6
+PKG_CAT:=zcat
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)"
+endef
+
+define Host/Install
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/mkdosfs $(STAGING_DIR_HOST)/bin/
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/mkdosfs
+endef
+
+$(eval $(call HostBuild))