aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-10 19:27:04 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-10 19:27:04 +0000
commit3a176b47feb39be96e6143428059ab0f99084820 (patch)
tree25d75e2f927e6f7bf2f8cf262a6795664a89c982 /tools/cmake
parent75377c05c9a514df55be2e7e6275dde0843e5cef (diff)
downloadmaster-187ad058-3a176b47feb39be96e6143428059ab0f99084820.tar.gz
master-187ad058-3a176b47feb39be96e6143428059ab0f99084820.tar.bz2
master-187ad058-3a176b47feb39be96e6143428059ab0f99084820.zip
[tools] cmake: link statically
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33114 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/cmake')
-rw-r--r--tools/cmake/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index 54c63757c7..6f6c28a9b0 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -15,4 +15,7 @@ PKG_MD5SUM:=e1b237aeaed880f65dec9c20602452f6
include $(INCLUDE_DIR)/host-build.mk
+HOST_CONFIGURE_CMD = \
+ LDFLAGS="$(HOST_LDFLAGS) -static" ./configure
+
$(eval $(call HostBuild))