aboutsummaryrefslogtreecommitdiffstats
path: root/tools/ccache
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-10 19:27:03 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-10 19:27:03 +0000
commit75377c05c9a514df55be2e7e6275dde0843e5cef (patch)
treefc048075cd2cbab18721940379c5d6f37fae62c7 /tools/ccache
parent63840cf7581f71514f0f54461dd1c950137666f2 (diff)
downloadmaster-187ad058-75377c05c9a514df55be2e7e6275dde0843e5cef.tar.gz
master-187ad058-75377c05c9a514df55be2e7e6275dde0843e5cef.tar.bz2
master-187ad058-75377c05c9a514df55be2e7e6275dde0843e5cef.zip
[tools] ccache: fix compilation, link statically
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33113 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/ccache')
-rw-r--r--tools/ccache/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/tools/ccache/Makefile b/tools/ccache/Makefile
index 2a43a7e225..5d464e7ded 100644
--- a/tools/ccache/Makefile
+++ b/tools/ccache/Makefile
@@ -16,7 +16,8 @@ PKG_MD5SUM:=80a698c22d0b06b19c88ac58e8d8b632
include $(INCLUDE_DIR)/host-build.mk
-HOSTCC:=$(HOSTCC_NOCACHE)
+HOST_LDFLAGS += -static
+HOST_CONFIGURE_VARS += CC="$(HOSTCC_NOCACHE)"
define Host/Install/ccache
$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
@@ -24,10 +25,6 @@ define Host/Install/ccache
endef
ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
- define Host/Compile
- $(MAKE) -C $(HOST_BUILD_DIR)
- endef
-
define Host/Clean
-$(MAKE) -C $(HOST_BUILD_DIR) uninstall
$(call Host/Clean/Default)