aboutsummaryrefslogtreecommitdiffstats
path: root/tools/ccache
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-01-15 11:43:13 +0000
committerJohn Crispin <blogic@openwrt.org>2012-01-15 11:43:13 +0000
commit1e0b48fafb133310de5e166adaf0c3957e7bee05 (patch)
tree5e1b24560a28f3d1faf6dc571355446688ffcdaa /tools/ccache
parent8f76568da91dbe989e5365a4a6d3f50847b1c755 (diff)
downloadmaster-187ad058-1e0b48fafb133310de5e166adaf0c3957e7bee05.tar.gz
master-187ad058-1e0b48fafb133310de5e166adaf0c3957e7bee05.tar.bz2
master-187ad058-1e0b48fafb133310de5e166adaf0c3957e7bee05.zip
tools: clean up Makefiles / make ccache work
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29754 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/ccache')
-rw-r--r--tools/ccache/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/tools/ccache/Makefile b/tools/ccache/Makefile
index ada929377a..21123b316d 100644
--- a/tools/ccache/Makefile
+++ b/tools/ccache/Makefile
@@ -19,11 +19,7 @@ include $(INCLUDE_DIR)/host-build.mk
ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
define Host/Compile
- $(MAKE) CC="$(HOSTCC)" -C $(HOST_BUILD_DIR)
- endef
-
- define Host/Install
- $(MAKE) -C $(HOST_BUILD_DIR) install
+ $(MAKE) CC="$(HOSTCC_NOCACHE)" -C $(HOST_BUILD_DIR)
endef
define Host/Clean
@@ -41,6 +37,8 @@ else
endef
define Host/Clean
endef
+ define Download
+ endef
endif
$(eval $(call HostBuild))