aboutsummaryrefslogtreecommitdiffstats
path: root/tools/b43-tools
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2013-02-28 10:43:02 +0000
committerHauke Mehrtens <hauke@openwrt.org>2013-02-28 10:43:02 +0000
commitb9491289f06c1d1923a626c61358ea5357e806e9 (patch)
treebf48e1d931f1e33be6b9a6354d836b786c3b1cd4 /tools/b43-tools
parent9e8653183ab83205806cd0de850c54d8adde67dd (diff)
downloadmaster-187ad058-b9491289f06c1d1923a626c61358ea5357e806e9.tar.gz
master-187ad058-b9491289f06c1d1923a626c61358ea5357e806e9.tar.bz2
master-187ad058-b9491289f06c1d1923a626c61358ea5357e806e9.zip
b43-tools: fix compile error: undefined reference to `yydebug'
With bison 2.7 YYDEBUG will be set to 0 if it was not set, then #ifdef YYDEBUG returns true, but bison 2.7 treets YYDEBUG 0 as not set. This fixes the following error: obj/main.o: In function `main': main.c:(.text.startup+0xaf): undefined reference to `yydebug' collect2: error: ld returned 1 exit status This closes #13093. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35830 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/b43-tools')
-rw-r--r--tools/b43-tools/patches/100-b43-asm-fix-compile-error-undefined-reference-to-yyd.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/tools/b43-tools/patches/100-b43-asm-fix-compile-error-undefined-reference-to-yyd.patch b/tools/b43-tools/patches/100-b43-asm-fix-compile-error-undefined-reference-to-yyd.patch
new file mode 100644
index 0000000000..fc0553d6be
--- /dev/null
+++ b/tools/b43-tools/patches/100-b43-asm-fix-compile-error-undefined-reference-to-yyd.patch
@@ -0,0 +1,27 @@
+--- a/assembler/Makefile
++++ b/assembler/Makefile
+@@ -30,7 +30,7 @@ BIN = b43-asm.bin
+ SRCS = parser.c scanner.c main.c initvals.c util.c args.c
+
+ # YACC related CFLAGS
+-CFLAGS += -DYYSTYPE="void *" -DYYERROR_VERBOSE -DYYDEBUG -DYYENABLE_NLS=0 -DYYLTYPE_IS_TRIVIAL=0 -Wno-unused
++CFLAGS += -DYYSTYPE="void *" -DYYERROR_VERBOSE -DYYDEBUG=1 -DYYENABLE_NLS=0 -DYYLTYPE_IS_TRIVIAL=0 -Wno-unused
+
+ .SUFFIXES:
+ .PHONY: all install clean distclean
+diff --git a/assembler/main.c b/assembler/main.c
+index afca996..a62a15e 100644
+--- a/assembler/main.c
++++ b/assembler/main.c
+@@ -1260,7 +1260,7 @@ static void initialize(void)
+ {
+ INIT_LIST_HEAD(&infile.sl);
+ INIT_LIST_HEAD(&infile.ivals);
+-#ifdef YYDEBUG
++#if YYDEBUG
+ if (IS_INSANE_DEBUG)
+ yydebug = 1;
+ else
+--
+1.7.10.4
+