aboutsummaryrefslogtreecommitdiffstats
path: root/tools/automake
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-13 07:49:01 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-13 07:49:01 +0000
commit5aa01e2480552f19e6bc14e4506351b268f22f73 (patch)
treeaa5e1e2bd4d479da8ce59f310cef82d8e1ad28cd /tools/automake
parentebc223a2173bb0c16c0fdff0aee0b269f1e8711d (diff)
downloadmaster-187ad058-5aa01e2480552f19e6bc14e4506351b268f22f73.tar.gz
master-187ad058-5aa01e2480552f19e6bc14e4506351b268f22f73.tar.bz2
master-187ad058-5aa01e2480552f19e6bc14e4506351b268f22f73.zip
tools: bootstrap automake to pickup the correct in-tree autoconf
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43958 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/automake')
-rw-r--r--tools/automake/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/tools/automake/Makefile b/tools/automake/Makefile
index 300bee21ea..8c390d48de 100644
--- a/tools/automake/Makefile
+++ b/tools/automake/Makefile
@@ -18,6 +18,11 @@ include $(INCLUDE_DIR)/host-build.mk
HOST_CONFIGURE_ARGS += --datarootdir=$(STAGING_DIR_HOST)/share
HOST_CONFIGURE_VARS += am_cv_prog_PERL_ithreads=no
+define Host/Configure
+ (cd $(HOST_BUILD_DIR); $(AM_TOOL_PATHS) STAGING_DIR="" ./bootstrap.sh)
+ $(call Host/Configure/Default)
+endef
+
define Host/Install
# remove old automake resources to avoid version conflicts
rm -rf $(STAGING_DIR_HOST)/share/aclocal-[0-9]*