aboutsummaryrefslogtreecommitdiffstats
path: root/tools/automake
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-12-25 00:27:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-12-25 00:27:32 +0000
commit294dc8b19d8a6422171ae16c686a8767fe96d72d (patch)
treef23dd6664db64c0d53560d756a6070155e587282 /tools/automake
parent677f8f10bcbec6c63eca8c3a31616a6cb35a72d5 (diff)
downloadmaster-187ad058-294dc8b19d8a6422171ae16c686a8767fe96d72d.tar.gz
master-187ad058-294dc8b19d8a6422171ae16c686a8767fe96d72d.tar.bz2
master-187ad058-294dc8b19d8a6422171ae16c686a8767fe96d72d.zip
add automake to tools/
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9901 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/automake')
-rw-r--r--tools/automake/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/tools/automake/Makefile b/tools/automake/Makefile
new file mode 100644
index 0000000000..cf39cbda8b
--- /dev/null
+++ b/tools/automake/Makefile
@@ -0,0 +1,38 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=automake
+PKG_VERSION:=1.9.6
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@GNU/automake
+PKG_MD5SUM:=c11b8100bb311492d8220378fd8bf9e0
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Build/Configure
+ $(call Build/Configure/Default,\
+ --datarootdir=$(STAGING_DIR_HOST)/share \
+ )
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
+define Build/Install
+ $(MAKE) -C $(PKG_BUILD_DIR) install
+endef
+
+define Build/Clean
+ $(MAKE) -C $(PKG_BUILD_DIR) uninstall
+ $(MAKE) -C $(PKG_BUILD_DIR) clean
+ $(call Build/Clean/Default)
+endef
+
+$(eval $(call HostBuild))