aboutsummaryrefslogtreecommitdiffstats
path: root/tools/automake
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-10 16:03:27 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-10 16:03:27 +0000
commit1998779bd6d6ac8a4af990f1663581bf49ee6a23 (patch)
tree85e7f2dfdbf2e06e3a0acd7ab166ed97c3ea4377 /tools/automake
parentd47f844c99f375f80143257991ff554ab1123807 (diff)
downloadmaster-187ad058-1998779bd6d6ac8a4af990f1663581bf49ee6a23.tar.gz
master-187ad058-1998779bd6d6ac8a4af990f1663581bf49ee6a23.tar.bz2
master-187ad058-1998779bd6d6ac8a4af990f1663581bf49ee6a23.zip
[tools] automake: use symlinks instead of hardlinks to link aclocal versions
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24425 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/automake')
-rw-r--r--tools/automake/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/tools/automake/Makefile b/tools/automake/Makefile
index 932d3ee847..ee7966aeeb 100644
--- a/tools/automake/Makefile
+++ b/tools/automake/Makefile
@@ -29,10 +29,10 @@ define Host/Install
$(MAKE) -C $(HOST_BUILD_DIR) install
mv $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal.real
$(INSTALL_BIN) ./files/aclocal $(STAGING_DIR_HOST)/bin
- ln -f $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.9
- ln -f $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.10
- ln -f $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11
- ln -f $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11.1
+ ln -sf $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.9
+ ln -sf $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.10
+ ln -sf $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11
+ ln -sf $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11.1
endef
define Host/Clean