aboutsummaryrefslogtreecommitdiffstats
path: root/tools/autoconf
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-22 04:37:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-22 04:37:20 +0000
commitb892e1fb855de59ce8e81881526ede35df1ae3fd (patch)
tree8497134d453d336d68b5dbf67d9b6b719ed2145e /tools/autoconf
parent67c9c212e61d7ce11aa22e3ac5f7a109c134c0d1 (diff)
downloadmaster-187ad058-b892e1fb855de59ce8e81881526ede35df1ae3fd.tar.gz
master-187ad058-b892e1fb855de59ce8e81881526ede35df1ae3fd.tar.bz2
master-187ad058-b892e1fb855de59ce8e81881526ede35df1ae3fd.zip
build system refactoring in preparation for allowing packages to do host-build steps
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14610 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/autoconf')
-rw-r--r--tools/autoconf/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/tools/autoconf/Makefile b/tools/autoconf/Makefile
index 30ca2d28d1..12bbaba255 100644
--- a/tools/autoconf/Makefile
+++ b/tools/autoconf/Makefile
@@ -15,23 +15,23 @@ PKG_MD5SUM:=e1fb8fe0b22e651240afdfa2be537a3c
include $(INCLUDE_DIR)/host-build.mk
-define Build/Configure
- $(call Build/Configure/Default,\
+define Host/Configure
+ $(call Host/Configure/Default,\
--datarootdir=$(STAGING_DIR_HOST)/share \
)
endef
-define Build/Compile
- export SHELL="$(BASH)"; $(MAKE) -C $(PKG_BUILD_DIR)
+define Host/Compile
+ export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR)
endef
-define Build/Install
- export SHELL="$(BASH)"; $(MAKE) -C $(PKG_BUILD_DIR) install
+define Host/Install
+ export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) install
endef
-define Build/Clean
- export SHELL="$(BASH)"; $(MAKE) -C $(PKG_BUILD_DIR) uninstall
- $(call Build/Clean/Default)
+define Host/Clean
+ export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
endef
$(eval $(call HostBuild))