aboutsummaryrefslogtreecommitdiffstats
path: root/tools/autoconf
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-09-08 15:59:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-09-08 15:59:08 +0000
commit61ff1187be74718e2e2a1eed611473f201f275b1 (patch)
treef917688036f48da2039c43d801e395ff0cd2ec28 /tools/autoconf
parent9f40ecda1f5d604022aa28e5d7fbeea3697fe5e2 (diff)
downloadmaster-187ad058-61ff1187be74718e2e2a1eed611473f201f275b1.tar.gz
master-187ad058-61ff1187be74718e2e2a1eed611473f201f275b1.tar.bz2
master-187ad058-61ff1187be74718e2e2a1eed611473f201f275b1.zip
fix autoconf compilation (#3956)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12554 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/autoconf')
-rw-r--r--tools/autoconf/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/tools/autoconf/Makefile b/tools/autoconf/Makefile
index cf66563ea0..30ca2d28d1 100644
--- a/tools/autoconf/Makefile
+++ b/tools/autoconf/Makefile
@@ -22,16 +22,15 @@ define Build/Configure
endef
define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR)
+ export SHELL="$(BASH)"; $(MAKE) -C $(PKG_BUILD_DIR)
endef
define Build/Install
- $(MAKE) -C $(PKG_BUILD_DIR) install
+ export SHELL="$(BASH)"; $(MAKE) -C $(PKG_BUILD_DIR) install
endef
define Build/Clean
- $(MAKE) -C $(PKG_BUILD_DIR) uninstall
- $(MAKE) -C $(PKG_BUILD_DIR) clean
+ export SHELL="$(BASH)"; $(MAKE) -C $(PKG_BUILD_DIR) uninstall
$(call Build/Clean/Default)
endef