aboutsummaryrefslogtreecommitdiffstats
path: root/tools/autoconf
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-08-27 20:18:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-08-27 20:18:53 +0000
commit533c261d295221197e78a4dfea0063ceb9a81f05 (patch)
treeabdce4c4890d7b2e367ad012c58019e4df1b39eb /tools/autoconf
parentf56b26987b8540ae5ca1c2a3343e4a1a0652a5c0 (diff)
downloadmaster-187ad058-533c261d295221197e78a4dfea0063ceb9a81f05.tar.gz
master-187ad058-533c261d295221197e78a4dfea0063ceb9a81f05.tar.bz2
master-187ad058-533c261d295221197e78a4dfea0063ceb9a81f05.zip
add autoconf (fixes opkg build issues)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12410 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/autoconf')
-rw-r--r--tools/autoconf/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/tools/autoconf/Makefile b/tools/autoconf/Makefile
new file mode 100644
index 0000000000..cf66563ea0
--- /dev/null
+++ b/tools/autoconf/Makefile
@@ -0,0 +1,38 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=autoconf
+PKG_VERSION:=2.62
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@GNU/autoconf
+PKG_MD5SUM:=e1fb8fe0b22e651240afdfa2be537a3c
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Build/Configure
+ $(call Build/Configure/Default,\
+ --datarootdir=$(STAGING_DIR_HOST)/share \
+ )
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
+define Build/Install
+ $(MAKE) -C $(PKG_BUILD_DIR) install
+endef
+
+define Build/Clean
+ $(MAKE) -C $(PKG_BUILD_DIR) uninstall
+ $(MAKE) -C $(PKG_BUILD_DIR) clean
+ $(call Build/Clean/Default)
+endef
+
+$(eval $(call HostBuild))