aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-10 15:48:32 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-10 15:48:32 +0000
commitfc7067b6aea353eab05fb59d1812b3308d529dca (patch)
tree29ba36d6b7e65395ca51e84ba4c79822f256070e /tools/Makefile
parent7ab21cefc337a91a736ac4d670e8b641ff061ef7 (diff)
downloadmaster-187ad058-fc7067b6aea353eab05fb59d1812b3308d529dca.tar.gz
master-187ad058-fc7067b6aea353eab05fb59d1812b3308d529dca.tar.bz2
master-187ad058-fc7067b6aea353eab05fb59d1812b3308d529dca.zip
tools: add patchelf host build
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44376 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index b4938d3a08..93aa5b3e6c 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -28,7 +28,7 @@ tools-y += m4 libtool autoconf automake flex bison pkg-config sed mklibs
tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
tools-y += firmware-utils patch-image patch quilt yaffs2 flock padjffs2
tools-y += mm-macros xorg-macros xfce-macros missing-macros xz cmake scons bc
-tools-y += findutils gengetopt
+tools-y += findutils gengetopt patchelf
tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
tools-$(CONFIG_powerpc) += upx
tools-$(CONFIG_TARGET_x86) += qemu
@@ -74,6 +74,7 @@ $(curdir)/cloog/compile := $(curdir)/ppl/install
$(curdir)/bc/compile := $(curdir)/bison/install
$(curdir)/findutils/compile := $(curdir)/bison/install
$(curdir)/gengetopt/compile := $(curdir)/libtool/install
+$(curdir)/patchelf/compile := $(curdir)/libtool/install
ifneq ($(CONFIG_CCACHE),)
$(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))