aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-06 09:56:12 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-06 09:56:12 +0000
commitb5fac0256a30aa417ed90e02afc2d600b367c775 (patch)
tree4a47f88eda3b6d6498efa904aad5b15873399f00 /tools/Makefile
parent9dd8b818459c5118b5acc3e17e70e1fae293fddd (diff)
downloadmaster-187ad058-b5fac0256a30aa417ed90e02afc2d600b367c775.tar.gz
master-187ad058-b5fac0256a30aa417ed90e02afc2d600b367c775.tar.bz2
master-187ad058-b5fac0256a30aa417ed90e02afc2d600b367c775.zip
small cleanup for tools/Makefile
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15111 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 88755aeadd..49c450f27f 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -9,7 +9,11 @@
curdir:=tools
# subdirectories to descend into
-$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config m4 autoconf automake $(if $(CONFIG_CCACHE),ccache) bison $(if $(CONFIG_powerpc),dtc) quilt $(if $(CONFIG_GCC_VERSION_4_3),gmp mpfr) yaffs2
+tools-y := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config m4 autoconf automake bison quilt yaffs2
+
+tools-$(CONFIG_CCACHE) += ccache
+tools-$(CONFIG_powerpc) += dtc
+tools-$(CONFIG_GCC_VERSION_4_3) += gmp mpfr
# builddir dependencies
$(curdir)/squashfs/compile := $(curdir)/lzma/install
@@ -18,6 +22,9 @@ $(curdir)/dtc/compile := $(curdir)/bison/install
$(curdir)/autoconf/compile := $(curdir)/m4/install
$(curdir)/automake/compile := $(curdir)/m4/install
+$(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
+$(curdir)/builddirs-default := $(tools-y)
+
# preparatory work
$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
@for dir in $(STAGING_DIR) $(STAGING_DIR_HOST); do ( \