aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-09-11 18:38:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-09-11 18:38:02 +0000
commitb412d6352aada99f9d64931501bb9fa43f9e21c2 (patch)
tree3cf2b3c5cdfde2ef3a8a1672570090ab602451af /tools/Makefile
parent1f9e25d6dd7870572c6686793af1aeb160eec558 (diff)
downloadmaster-187ad058-b412d6352aada99f9d64931501bb9fa43f9e21c2.tar.gz
master-187ad058-b412d6352aada99f9d64931501bb9fa43f9e21c2.tar.bz2
master-187ad058-b412d6352aada99f9d64931501bb9fa43f9e21c2.zip
tools: add tar host build, required for --sort=name which was only added in the latest version
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46876 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 60041ddc31..dda429f935 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -81,6 +81,9 @@ endif
# dependency for tools which have patches directory
$(foreach tool, $(tools-y), $(if $(wildcard $(curdir)/$(tool)/patches),$(eval $(curdir)/$(tool)/compile += $(curdir)/patch/install)))
+$(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/tar/install))
+tools-y += tar
+
$(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
$(curdir)/builddirs-default := $(tools-y)