aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-24 01:18:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-24 01:18:49 +0000
commit8f2e42b5b7b768e22e0f35c493de40d349443b2e (patch)
tree389caed9bbe54bb09a953ffebee5ed0143d081a7 /tools/Makefile
parenta47aac47e62a809db7e86b48877e277a4d746105 (diff)
downloadmaster-187ad058-8f2e42b5b7b768e22e0f35c493de40d349443b2e.tar.gz
master-187ad058-8f2e42b5b7b768e22e0f35c493de40d349443b2e.tar.bz2
master-187ad058-8f2e42b5b7b768e22e0f35c493de40d349443b2e.zip
optimize tools/ directory build order to improve parallel building performance
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15365 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 72a25b5b0c..54520bc75c 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -9,11 +9,14 @@
curdir:=tools
# subdirectories to descend into
-tools-y := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config m4 autoconf automake bison quilt yaffs2
+tools-y :=
+tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
+tools-y += m4 autoconf automake bison pkg-config sed
+tools-y += sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage
+tools-y += firmware-utils patch-cmdline quilt yaffs2
tools-$(CONFIG_CCACHE) += ccache
tools-$(CONFIG_powerpc) += dtc
-tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
# builddir dependencies
$(curdir)/squashfs/compile := $(curdir)/lzma/install