aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-07-20 10:50:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-07-20 10:50:46 +0000
commit4528054bb8a6ac70f5b996001abf5cfb5b316d1b (patch)
treeff21df319c03bec8ff38bcfebb896bc3d9a195f6 /tools/Makefile
parent68c971756a0af802f91a80a1f9b616e1e049f643 (diff)
downloadmaster-187ad058-4528054bb8a6ac70f5b996001abf5cfb5b316d1b.tar.gz
master-187ad058-4528054bb8a6ac70f5b996001abf5cfb5b316d1b.tar.bz2
master-187ad058-4528054bb8a6ac70f5b996001abf5cfb5b316d1b.zip
tools: drop circular dependency between patch and ccache, build patch without ccache (fixes #20132)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46434 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 8b5dd6c520..60041ddc31 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -73,7 +73,7 @@ $(curdir)/gengetopt/compile := $(curdir)/libtool/install
$(curdir)/patchelf/compile := $(curdir)/libtool/install
ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)
-$(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))
+$(foreach tool, $(filter-out patch,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))
tools-y += ccache
endif