aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-09-27 12:49:34 +0000
committerLuka Perkov <luka@openwrt.org>2013-09-27 12:49:34 +0000
commit310c09d9f1fe85a646c1458c9631740d08e29725 (patch)
tree8444253f21ffc6c288da2c56e15f056da628faef /tools/Makefile
parenta1b2c26eb2310308fac7447b50ced169fb2fe925 (diff)
downloadmaster-187ad058-310c09d9f1fe85a646c1458c9631740d08e29725.tar.gz
master-187ad058-310c09d9f1fe85a646c1458c9631740d08e29725.tar.bz2
master-187ad058-310c09d9f1fe85a646c1458c9631740d08e29725.zip
[tools] patch: other tools might depend on this one
Signed-off-by: Markus Stenberg <markus.stenberg@iki.fi> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38236 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 6b846f8ef1..b167a60544 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -74,6 +74,10 @@ $(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache
tools-y += ccache
endif
+# in case there is no patch tool on the host we need to make patch tool a
+# dependency for tools which have patches directory
+$(foreach tool, $(tools-y), $(if $(wildcard $(curdir)/$(tool)/patches),$(eval $(curdir)/$(tool)/compile += $(curdir)/patch/install)))
+
$(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
$(curdir)/builddirs-default := $(tools-y)