aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-09-03 10:27:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-09-03 10:27:25 +0000
commit208c2c72eb1e34e8b5be73ae9e737be7ee8773ab (patch)
treecc349111a476fe54a642840318df5d9ccc5676af /tools/Makefile
parent1328d9a59d91adebe84471f1bda2c576a33faba3 (diff)
downloadmaster-187ad058-208c2c72eb1e34e8b5be73ae9e737be7ee8773ab.tar.gz
master-187ad058-208c2c72eb1e34e8b5be73ae9e737be7ee8773ab.tar.bz2
master-187ad058-208c2c72eb1e34e8b5be73ae9e737be7ee8773ab.zip
fix recursive symlink issue
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12508 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index f21b5a5820..e15f061a4d 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -38,7 +38,7 @@ $(STAGING_DIR_HOST)/bin/md5sum: $(STAGING_DIR)/.prepared
fi
$(STAGING_DIR_HOST)/bin/find: $(STAGING_DIR)/.prepared
- [ -x "$(FIND)" ] && ln -sf "$(FIND)" $@
+ [ -x "$(FIND)" -a "$(FIND)" != "$@" ] && ln -sf "$(FIND)" $@
$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum)