aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-13 11:35:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-13 11:35:37 +0000
commit0b2c82f19f8b792fb4ff21d35fb9ca479cd50b71 (patch)
treecc81f37db66693a2729bfb1e9efb6184b69833cc /tools/Makefile
parent6ba8cb4cf1f9ad46dcf0c7e34197432914817c9b (diff)
downloadmaster-187ad058-0b2c82f19f8b792fb4ff21d35fb9ca479cd50b71.tar.gz
master-187ad058-0b2c82f19f8b792fb4ff21d35fb9ca479cd50b71.tar.bz2
master-187ad058-0b2c82f19f8b792fb4ff21d35fb9ca479cd50b71.zip
tools: add isl (used for graphite on GCC 5)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47464 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/tools/Makefile b/tools/Makefile
index df384d4a90..346f0e9f38 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -13,10 +13,14 @@ tools-y :=
ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
BUILD_TOOLCHAIN := y
-endif
-ifdef CONFIG_GCC_USE_GRAPHITE
- ifeq ($(CONFIG_GCC_USE_SYSTEM_PPL_CLOOG),)
- BUILD_PPL_CLOOG = y
+ ifdef CONFIG_GCC_USE_GRAPHITE
+ ifneq ($(CONFIG_GCC_VERSION_4_8),)
+ ifeq ($(CONFIG_GCC_USE_SYSTEM_PPL_CLOOG),)
+ BUILD_PPL_CLOOG = y
+ endif
+ else
+ BUILD_ISL = y
+ endif
endif
endif
ifneq ($(CONFIG_PACKAGE_kmod-b43)$(CONFIG_PACKAGE_kmod-b43legacy)$(CONFIG_BRCMSMAC_USE_FW_FROM_WL),)
@@ -37,6 +41,7 @@ tools-$(CONFIG_TARGET_ar71xx) += lzma-old squashfs
tools-y += lzma squashfs4
tools-$(BUILD_B43_TOOLS) += b43-tools
tools-$(BUILD_PPL_CLOOG) += ppl cloog
+tools-$(BUILD_ISL) += isl
tools-$(CONFIG_USE_SPARSE) += sparse
# builddir dependencies
@@ -67,6 +72,7 @@ $(curdir)/sdcc/compile := $(curdir)/bison/install
$(curdir)/b43-tools/compile := $(curdir)/bison/install
$(curdir)/padjffs2/compile := $(curdir)/findutils/install
$(curdir)/cloog/compile := $(curdir)/ppl/install
+$(curdir)/isl/compile := $(curdir)/gmp/install
$(curdir)/bc/compile := $(curdir)/bison/install
$(curdir)/findutils/compile := $(curdir)/bison/install
$(curdir)/gengetopt/compile := $(curdir)/libtool/install