aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-10 21:10:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-10 21:10:45 +0000
commite759507ac8e84e8ff6e5c7cf4e2b9a7c97f9a5b2 (patch)
tree90dacf58fe6b0111f53b901a3ca3d5de2b934384 /toolchain
parent0943a959762d9366f432c39e55d3b5279e054e75 (diff)
downloadmaster-187ad058-e759507ac8e84e8ff6e5c7cf4e2b9a7c97f9a5b2.tar.gz
master-187ad058-e759507ac8e84e8ff6e5c7cf4e2b9a7c97f9a5b2.tar.bz2
master-187ad058-e759507ac8e84e8ff6e5c7cf4e2b9a7c97f9a5b2.zip
gcc: enable LTO support unconditionally
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47442 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/final/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/toolchain/gcc/final/Makefile b/toolchain/gcc/final/Makefile
index 1212d145ab..3434d894a2 100644
--- a/toolchain/gcc/final/Makefile
+++ b/toolchain/gcc/final/Makefile
@@ -8,13 +8,9 @@ GCC_CONFIGURE += \
--enable-languages=$(TARGET_LANGUAGES) \
--enable-shared \
--enable-threads \
- --with-slibdir=$(TOOLCHAIN_DIR)/lib
-
-ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
- GCC_CONFIGURE += \
+ --with-slibdir=$(TOOLCHAIN_DIR)/lib \
--enable-lto \
--with-libelf=$(TOPDIR)/staging_dir/host
-endif
ifdef CONFIG_USE_MUSL
GCC_MAKE += gcc_cv_libc_provides_ssp=yes