aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-13 11:35:41 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-13 11:35:41 +0000
commite6a8125fa4dad40b6042bfa544bb85b0e59cdad4 (patch)
tree82bab562d0b65d727d68348ef0e3bc70fe0a9278 /toolchain
parent0b2c82f19f8b792fb4ff21d35fb9ca479cd50b71 (diff)
downloadmaster-187ad058-e6a8125fa4dad40b6042bfa544bb85b0e59cdad4.tar.gz
master-187ad058-e6a8125fa4dad40b6042bfa544bb85b0e59cdad4.tar.bz2
master-187ad058-e6a8125fa4dad40b6042bfa544bb85b0e59cdad4.zip
gcc: set the isl/cloog prefix when graphite is enabled, disable it explicitly if it is disabled in the config
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47465 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/common.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 5214765d6b..0ac7de19f5 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -108,6 +108,16 @@ ifdef CONFIG_USE_UCLIBC
export glibcxx_cv_c99_math_tr1=no
endif
+ifdef CONFIG_GCC_USE_GRAPHITE
+ ifdef CONFIG_GCC_VERSION_4_8
+ GRAPHITE_CONFIGURE=--with-cloog=$(REAL_STAGING_DIR_HOST)
+ else
+ GRAPHITE_CONFIGURE=--with-isl=$(REAL_STAGING_DIR_HOST)
+ endif
+else
+ GRAPHITE_CONFIGURE=--without-isl --without-cloog
+endif
+
GCC_CONFIGURE:= \
SHELL="$(BASH)" \
$(if $(shell gcc --version 2>&1 | grep LLVM), \