aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-01-13 02:15:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-01-13 02:15:14 +0000
commitc4ed52f907926038bd9524dc998517cea6cddd19 (patch)
tree757357f4b1ccb4b0edbe3b62e1101554ed1e7869 /toolchain
parent285e15805ddc0b1d305e8abd11b0f11a4743e9dc (diff)
downloadmaster-187ad058-c4ed52f907926038bd9524dc998517cea6cddd19.tar.gz
master-187ad058-c4ed52f907926038bd9524dc998517cea6cddd19.tar.bz2
master-187ad058-c4ed52f907926038bd9524dc998517cea6cddd19.zip
uclibc: add some libpthread fixes
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14013 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/uClibc/patches/190-install_tls.patch12
-rw-r--r--toolchain/uClibc/patches/200-libpthread_static.patch11
2 files changed, 23 insertions, 0 deletions
diff --git a/toolchain/uClibc/patches/190-install_tls.patch b/toolchain/uClibc/patches/190-install_tls.patch
new file mode 100644
index 0000000000..74d403265c
--- /dev/null
+++ b/toolchain/uClibc/patches/190-install_tls.patch
@@ -0,0 +1,12 @@
+--- a/libpthread/linuxthreads/Makefile.in
++++ b/libpthread/linuxthreads/Makefile.in
+@@ -128,7 +128,9 @@ linuxthreads_headers:
+ $(Q)$(LN) -sf ../$(PTDIR)/sysdeps/pthread/pthread.h $(top_builddir)include/
+ $(Q)$(LN) -sf ../$(PTDIR)/semaphore.h $(top_builddir)include/
+ $(Q)$(INSTALL) -d $(top_builddir)include/bits
++ $(Q)$(INSTALL) -d $(top_builddir)include/sys
+ $(Q)$(LN) -sf ../../$(PTDIR)/sysdeps/pthread/bits/pthreadtypes.h $(top_builddir)include/bits/
++ $(Q)$(LN) -sf ../../$(PTDIR)/sysdeps/$(TARGET_ARCH)/tls.h $(top_builddir)include/sys/
+
+ linuxthreads_headers_clean:
+ $(RM) $(top_builddir)include/pthread.h $(top_builddir)include/semaphore.h \
diff --git a/toolchain/uClibc/patches/200-libpthread_static.patch b/toolchain/uClibc/patches/200-libpthread_static.patch
new file mode 100644
index 0000000000..269370d075
--- /dev/null
+++ b/toolchain/uClibc/patches/200-libpthread_static.patch
@@ -0,0 +1,11 @@
+--- a/libpthread/linuxthreads/Makefile.in
++++ b/libpthread/linuxthreads/Makefile.in
+@@ -65,7 +65,7 @@ CFLAGS-OMIT-libc_pthread_init.c := $(CFL
+ libpthread_libc_CSRC := \
+ forward.c libc-cancellation.c libc_pthread_init.c # alloca_cutoff.c
+ libpthread_libc_OBJ := $(patsubst %.c, $(libpthread_OUT)/%.o,$(libpthread_libc_CSRC))
+-libc-static-y += $(libpthread_OUT)/libc_pthread_init.o
++libc-static-y += $(libpthread_OUT)/libc_pthread_init.o $(libpthread_OUT)/libc-cancellation.o
+ libc-shared-y += $(libpthread_libc_OBJ:.o=.oS)
+
+ libpthread-static-y += $(patsubst %,$(libpthread_OUT)/%.o,$(libpthread_static_SRC))