aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-20 19:12:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-20 19:12:01 +0000
commitb31d6f5d303f91b9f04adb323ba785186a1ab43e (patch)
tree427bb63de9399844dbda526b01772e2f62c61d6b /toolchain
parent1da4c3587891cd86c204ffe1cbfc9beb9d1f2313 (diff)
downloadmaster-187ad058-b31d6f5d303f91b9f04adb323ba785186a1ab43e.tar.gz
master-187ad058-b31d6f5d303f91b9f04adb323ba785186a1ab43e.tar.bz2
master-187ad058-b31d6f5d303f91b9f04adb323ba785186a1ab43e.zip
toolchain: Reverse glibc/eglibc conditionals to check for eglibc
This will make adding future glibc versions easier because the conditionals won't have to be modified again. Signed-off-by: Michael Marley <michael@michaelmarley.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48399 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/glibc/common.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/toolchain/glibc/common.mk b/toolchain/glibc/common.mk
index 052050576a..bc50fcb69e 100644
--- a/toolchain/glibc/common.mk
+++ b/toolchain/glibc/common.mk
@@ -72,10 +72,10 @@ export HOST_CFLAGS := $(HOST_CFLAGS) -idirafter $(CURDIR)/$(PATH_PREFIX)/include
define Host/SetToolchainInfo
$(SED) 's,^\(LIBC_TYPE\)=.*,\1=$(PKG_NAME),' $(TOOLCHAIN_DIR)/info.mk
-ifneq ($(CONFIG_GLIBC_VERSION_2_21),)
- $(SED) 's,^\(LIBC_URL\)=.*,\1=http://www.gnu.org/software/libc/,' $(TOOLCHAIN_DIR)/info.mk
-else
+ifneq ($(CONFIG_EGLIBC_VERSION_2_19),)
$(SED) 's,^\(LIBC_URL\)=.*,\1=http://www.eglibc.org/,' $(TOOLCHAIN_DIR)/info.mk
+else
+ $(SED) 's,^\(LIBC_URL\)=.*,\1=http://www.gnu.org/software/libc/,' $(TOOLCHAIN_DIR)/info.mk
endif
$(SED) 's,^\(LIBC_VERSION\)=.*,\1=$(PKG_VERSION),' $(TOOLCHAIN_DIR)/info.mk
$(SED) 's,^\(LIBC_SO_VERSION\)=.*,\1=$(PKG_VERSION),' $(TOOLCHAIN_DIR)/info.mk
@@ -97,7 +97,7 @@ endef
define Host/Prepare
$(call Host/Prepare/Default)
ln -snf $(PKG_SOURCE_SUBDIR) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
-ifeq ($(CONFIG_GLIBC_VERSION_2_21)$(CONFIG_GLIBC_VERSION_2_22),)
+ifneq ($(CONFIG_EGLIBC_VERSION_2_19),)
$(SED) 's,y,n,' $(HOST_BUILD_DIR)/libc/option-groups.defaults
endif
endef