aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorMirko Vogt <mirko@openwrt.org>2011-06-18 11:14:05 +0000
committerMirko Vogt <mirko@openwrt.org>2011-06-18 11:14:05 +0000
commit8fd46011a89c8dd0459ebe0ed6f91878054fe0ab (patch)
treeb18952ad0ee75c1693f66fde66bc71f1b6648f81 /toolchain
parent0cb5e9240088c27524ec1dd5be5dbe43ede27c03 (diff)
downloadmaster-187ad058-8fd46011a89c8dd0459ebe0ed6f91878054fe0ab.tar.gz
master-187ad058-8fd46011a89c8dd0459ebe0ed6f91878054fe0ab.tar.bz2
master-187ad058-8fd46011a89c8dd0459ebe0ed6f91878054fe0ab.zip
[toolchain/eglibc] add support for eglibc version 2.13
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27215 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/eglibc/Config.in5
-rw-r--r--toolchain/eglibc/Config.version1
-rw-r--r--toolchain/eglibc/Makefile3
3 files changed, 9 insertions, 0 deletions
diff --git a/toolchain/eglibc/Config.in b/toolchain/eglibc/Config.in
index 1800d7c6dd..2054e95b5d 100644
--- a/toolchain/eglibc/Config.in
+++ b/toolchain/eglibc/Config.in
@@ -28,6 +28,10 @@ choice
bool "eglibc 2.12"
depends !GCC_VERSION_LLVM
+ config EGLIBC_VERSION_2_13
+ bool "eglibc 2.13"
+ depends !GCC_VERSION_LLVM
+
config EGLIBC_VERSION_TRUNK
bool "eglibc trunk"
@@ -44,6 +48,7 @@ config EGLIBC_REVISION
default "10152" if EGLIBC_VERSION_2_10
default "10454" if EGLIBC_VERSION_2_11
default "10495" if EGLIBC_VERSION_2_12
+ default "13055" if EGLIBC_VERSION_2_13
default "HEAD" if EGLIBC_VERSION_TRUNK
default ""
diff --git a/toolchain/eglibc/Config.version b/toolchain/eglibc/Config.version
index 700c40924e..b3e2a15b0f 100644
--- a/toolchain/eglibc/Config.version
+++ b/toolchain/eglibc/Config.version
@@ -8,4 +8,5 @@ config EGLIBC_VERSION
default "2.10.2" if EGLIBC_VERSION_2_10
default "2.11.1" if EGLIBC_VERSION_2_11
default "2.12" if EGLIBC_VERSION_2_12
+ default "2.13" if EGLIBC_VERSION_2_13
default "trunk"
diff --git a/toolchain/eglibc/Makefile b/toolchain/eglibc/Makefile
index 5d34c95531..6be809745b 100644
--- a/toolchain/eglibc/Makefile
+++ b/toolchain/eglibc/Makefile
@@ -36,6 +36,9 @@ endif
ifneq ($(CONFIG_EGLIBC_VERSION_2_12),)
PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_12
endif
+ifneq ($(CONFIG_EGLIBC_VERSION_2_13),)
+ PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_13
+endif
ifneq ($(CONFIG_EGLIBC_VERSION_TRUNK),)
PKG_SOURCE_URL:=svn://svn.eglibc.org/trunk
endif