aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-04-10 14:05:38 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-04-10 14:05:38 +0000
commit6e62677c0558d4a02eb84f8fc564d168c96c83d3 (patch)
treee93f9a1d7c67d4d0034ecfa28b9b1597a000a4ef /toolchain
parent3435766c70d68d782dd187bb4ebbb88a7617015f (diff)
downloadmaster-187ad058-6e62677c0558d4a02eb84f8fc564d168c96c83d3.tar.gz
master-187ad058-6e62677c0558d4a02eb84f8fc564d168c96c83d3.tar.bz2
master-187ad058-6e62677c0558d4a02eb84f8fc564d168c96c83d3.zip
Disable tls support, uClibc does not support it, and it could lead to linking failures with some braindead autoconf programs
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10782 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index a1d1baa400..57118bb119 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -60,6 +60,7 @@ define Stage1/Configure
--disable-nls \
--disable-libmudflap \
--disable-multilib \
+ --disable-tls \
$(SOFT_FLOAT_CONFIG_OPTION) \
$(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
);
@@ -93,6 +94,7 @@ define Stage2/Configure
--disable-nls \
--disable-libmudflap \
--disable-multilib \
+ --disable-tls \
$(SOFT_FLOAT_CONFIG_OPTION) \
$(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
);