aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-25 14:12:44 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-25 14:12:44 +0000
commit43d6387a897b300d07c7c6a762bc21a6500233a8 (patch)
tree5a66f3048120911368c22e2355d0a72a630daad1 /toolchain
parenta09a31be5ab0a1b069d3614d39fae575c526f6b0 (diff)
downloadmaster-187ad058-43d6387a897b300d07c7c6a762bc21a6500233a8.tar.gz
master-187ad058-43d6387a897b300d07c7c6a762bc21a6500233a8.tar.bz2
master-187ad058-43d6387a897b300d07c7c6a762bc21a6500233a8.zip
gcc: make colors optional based on the GCC_COLORS env var
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47642 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/common.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 0ac7de19f5..3e4f3ee984 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -151,6 +151,10 @@ ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
GCC_CONFIGURE += --with-mips-plt
endif
+ifndef GCC_VERSION_4_8
+ GCC_CONFIGURE += --with-diagnostics-color=auto-if-env
+endif
+
ifneq ($(CONFIG_SSP_SUPPORT),)
GCC_CONFIGURE+= \
--enable-libssp