aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-05-12 19:08:03 +0000
committerMike Baker <mbm@openwrt.org>2006-05-12 19:08:03 +0000
commit20e4ecc021ee9aa4b799b065732f39d9daa5a2c5 (patch)
tree6c8591525420de7c8afd05b2261efe6b9071196a /toolchain
parent7b37cc4da9c275661854482bb61046d4d7a8435f (diff)
downloadmaster-187ad058-20e4ecc021ee9aa4b799b065732f39d9daa5a2c5.tar.gz
master-187ad058-20e4ecc021ee9aa4b799b065732f39d9daa5a2c5.tar.bz2
master-187ad058-20e4ecc021ee9aa4b799b065732f39d9daa5a2c5.zip
fix BR2_ and CONFIG_ issues
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3769 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/binutils/Makefile2
-rw-r--r--toolchain/gcc/Makefile8
-rw-r--r--toolchain/gdb/Config.in2
-rw-r--r--toolchain/uClibc/Makefile8
4 files changed, 10 insertions, 10 deletions
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index 1b205715e3..7d405664bb 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -5,7 +5,7 @@ include $(TOPDIR)/rules.mk
# build binutils for use on the host system
#
#############################################################
-BINUTILS_VERSION:=$(strip $(subst ",, $(BR2_BINUTILS_VERSION)))
+BINUTILS_VERSION:=$(strip $(subst ",, $(CONFIG_BINUTILS_VERSION)))
#"
BINUTILS_SITE:=http://www.fr.kernel.org/pub/linux/devel/binutils \
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index 26e17ad61e..cf60d75050 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -37,10 +37,10 @@ GCC_STRIP_HOST_BINARIES:=true
#
#############################################################
-ifeq ($(BR2_INSTALL_LIBGCJ),y)
+ifeq ($(CONFIG_INSTALL_LIBGCJ),y)
TARGET_LANGUAGES:=c,c++,java
else
-ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
+ifeq ($(CONFIG_INSTALL_LIBSTDCPP),y)
TARGET_LANGUAGES:=c,c++
else
TARGET_LANGUAGES:=c
@@ -71,7 +71,7 @@ $(GCC_DIR)/.patched: $(GCC_DIR)/.unpacked
# We can dispense with the custom spec files, as well as libfloat for the arm case.
# However, we still need a patch for arm. There's a similar patch for gcc 3.3.x
# which needs to be integrated so we can kill of libfloat for good.
-ifeq ($(BR2_SOFT_FLOAT),y)
+ifeq ($(CONFIG_SOFT_FLOAT),y)
ifeq ("$(strip $(ARCH))","arm")
$(SCRIPT_DIR)/patch-kernel.sh $(GCC_DIR) ./$(GCC_VERSION) arm-softfloat.patch.conditional
endif
@@ -175,7 +175,7 @@ gcc-install: $(GCC_BUILD_DIR2)/.compiled
#
# Now for the ugly 3.3.x soft float hack...
#
-ifeq ($(BR2_SOFT_FLOAT),y)
+ifeq ($(CONFIG_SOFT_FLOAT),y)
ifeq ($(findstring 3.3.,$(GCC_VERSION)),3.3.)
# Make sure we have a soft float specs file for this arch
if [ ! -f ./$(GCC_VERSION)/specs-$(ARCH)-soft-float ] ; then \
diff --git a/toolchain/gdb/Config.in b/toolchain/gdb/Config.in
index 574a398bb8..f8560cbd90 100644
--- a/toolchain/gdb/Config.in
+++ b/toolchain/gdb/Config.in
@@ -1,6 +1,6 @@
comment "Gdb Options"
-config BR2_PACKAGE_GDB_CLIENT
+config PACKAGE_GDB_CLIENT
bool "Build gdb client for the Host"
default n
help
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index d77f554a12..19ab0326f6 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -6,10 +6,10 @@ include $(TOPDIR)/rules.mk
#
#############################################################
-ifeq ($(BR2_UCLIBC_VERSION_SNAPSHOT),y)
+ifeq ($(CONFIG_UCLIBC_VERSION_SNAPSHOT),y)
# Be aware that this changes daily....
UCLIBC_DIR:=$(TOOL_BUILD_DIR)/uClibc
-UCLIBC_SOURCE:=uClibc-$(strip $(subst ",, $(BR2_USE_UCLIBC_SNAPSHOT))).tar.bz2
+UCLIBC_SOURCE:=uClibc-$(strip $(subst ",, $(CONFIG_USE_UCLIBC_SNAPSHOT))).tar.bz2
#"
UCLIBC_SITE:=http://www.uclibc.org/downloads/snapshots
UCLIBC_VER:=PKG_VERSION:=0.${shell date +"%G%m%d"}
@@ -50,13 +50,13 @@ $(UCLIBC_DIR)/.configured: $(UCLIBC_DIR)/.unpacked
$(CP) ./files/config.$(ARCH) $(UCLIBC_DIR)/.config
$(SED) 's,^KERNEL_SOURCE=.*,KERNEL_SOURCE=\"$(LINUX_HEADERS_DIR)\",g' \
$(UCLIBC_DIR)/.config
-ifeq ($(BR2_LARGEFILE),y)
+ifeq ($(CONFIG_LARGEFILE),y)
$(SED) 's,^.*UCLIBC_HAS_LFS.*,UCLIBC_HAS_LFS=y,g' $(UCLIBC_DIR)/.config
else
$(SED) 's,^.*UCLIBC_HAS_LFS.*,UCLIBC_HAS_LFS=n,g' $(UCLIBC_DIR)/.config
endif
$(SED) 's,.*UCLIBC_HAS_WCHAR.*,UCLIBC_HAS_WCHAR=y,g' $(UCLIBC_DIR)/.config
-ifeq ($(BR2_SOFT_FLOAT),y)
+ifeq ($(CONFIG_SOFT_FLOAT),y)
$(SED) 's,.*HAS_FPU.*,HAS_FPU=n\nUCLIBC_HAS_FLOATS=y\nUCLIBC_HAS_SOFT_FLOAT=y,g' $(UCLIBC_DIR)/.config
endif
mkdir -p $(TOOL_BUILD_DIR)/uClibc_dev/usr/include