aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/wrapper
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-02-20 15:06:10 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-02-20 15:06:10 +0000
commit5d7f822b6605be87aecedaf120df5110b594ebe4 (patch)
tree60e2c1d838268a4806574baf7268119a4255db9b /toolchain/wrapper
parentb80aa55594417b6b1188b860796fdcf4d925fc4e (diff)
downloadmaster-187ad058-5d7f822b6605be87aecedaf120df5110b594ebe4.tar.gz
master-187ad058-5d7f822b6605be87aecedaf120df5110b594ebe4.tar.bz2
master-187ad058-5d7f822b6605be87aecedaf120df5110b594ebe4.zip
buildroot: allow specifying libc personality for external toolchains
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35703 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/wrapper')
-rw-r--r--toolchain/wrapper/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/wrapper/Makefile b/toolchain/wrapper/Makefile
index 417ed8cd37..3398e407c9 100644
--- a/toolchain/wrapper/Makefile
+++ b/toolchain/wrapper/Makefile
@@ -17,7 +17,7 @@ include $(INCLUDE_DIR)/toolchain-build.mk
define toolchain_util
$(strip $(SCRIPT_DIR)/ext-toolchain.sh --toolchain $(CONFIG_TOOLCHAIN_ROOT) \
--cflags $(CONFIG_TARGET_OPTIMIZATION) \
- --cflags "-muclibc $(if $(CONFIG_SOFT_FLOAT),-msoft-float)" \
+ --cflags "$(if $(call qstrip,$(CONFIG_TOOLCHAIN_LIBC)),-m$(call qstrip,$(CONFIG_TOOLCHAIN_LIBC))) $(if $(CONFIG_SOFT_FLOAT),-msoft-float)" \
--cflags "$(patsubst ./%,-I$(TOOLCHAIN_ROOT_DIR)/%,$(call qstrip,$(CONFIG_TOOLCHAIN_INC_PATH)))" \
--cflags "$(patsubst ./%,-L$(TOOLCHAIN_ROOT_DIR)/%,$(call qstrip,$(CONFIG_TOOLCHAIN_LIB_PATH)))" \
$(1))