aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-08-14 13:02:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-08-14 13:02:29 +0000
commit64584aa1fcecfa733e4ef83d294280bce9f2922b (patch)
treef0eedc5fad943b44693a84a35e5c58140e6c5919 /toolchain/uClibc
parentec784b73562dc5afc0f6badb5b63fe02e58d237a (diff)
downloadmaster-187ad058-64584aa1fcecfa733e4ef83d294280bce9f2922b.tar.gz
master-187ad058-64584aa1fcecfa733e4ef83d294280bce9f2922b.tar.bz2
master-187ad058-64584aa1fcecfa733e4ef83d294280bce9f2922b.zip
build: decouple the mips16 support flag from the toolchain
Add the flags from package.mk instead, and leave libc and gcc unaffected. Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37770 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/uClibc')
-rw-r--r--toolchain/uClibc/common.mk2
1 files changed, 0 insertions, 2 deletions
diff --git a/toolchain/uClibc/common.mk b/toolchain/uClibc/common.mk
index f0a5b3d84f..69ac470b02 100644
--- a/toolchain/uClibc/common.mk
+++ b/toolchain/uClibc/common.mk
@@ -45,8 +45,6 @@ GEN_CONFIG=$(SCRIPT_DIR)/kconfig.pl -n \
$(if $(CONFIG_MIPS64_ABI),.$(subst ",,$(CONFIG_MIPS64_ABI)), \
$(if $(CONFIG_HAS_SPE_FPU),$(if $(wildcard $(CONFIG_DIR)/$(ARCH).e500),.e500)))))
-TARGET_CFLAGS := $(filter-out -mips16,$(TARGET_CFLAGS))
-
CPU_CFLAGS = \
-funsigned-char -fno-builtin -fno-asm \
--std=gnu99 -ffunction-sections -fdata-sections \