aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-06-30 07:54:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-06-30 07:54:51 +0000
commit5fca070da8a650af61617f8765b670dcedd195fe (patch)
tree664143f0182487bc2ea3b53b7fdddbae3db7d6f4 /toolchain/uClibc
parentd80c53a045d07f0f34d42222764e5c6b62b386d2 (diff)
downloadmaster-187ad058-5fca070da8a650af61617f8765b670dcedd195fe.tar.gz
master-187ad058-5fca070da8a650af61617f8765b670dcedd195fe.tar.bz2
master-187ad058-5fca070da8a650af61617f8765b670dcedd195fe.zip
uClibc: use position independent code for crt1, slightly reduces size of all executables
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37096 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/uClibc')
-rw-r--r--toolchain/uClibc/patches-0.9.33.2/210-mips_use_pic_crt1.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/toolchain/uClibc/patches-0.9.33.2/210-mips_use_pic_crt1.patch b/toolchain/uClibc/patches-0.9.33.2/210-mips_use_pic_crt1.patch
new file mode 100644
index 0000000000..2ca10d47cc
--- /dev/null
+++ b/toolchain/uClibc/patches-0.9.33.2/210-mips_use_pic_crt1.patch
@@ -0,0 +1,11 @@
+--- a/libc/sysdeps/linux/mips/Makefile.arch
++++ b/libc/sysdeps/linux/mips/Makefile.arch
+@@ -20,6 +20,8 @@ ifneq ($(UCLIBC_HAS_THREADS_NATIVE),y)
+ SSRC += vfork.S clone.S
+ endif
+
++CFLAGS-crt1.S += $(PICFLAG)
++
+ ASFLAGS-syscall_error.S += -D_LIBC_REENTRANT
+
+ ARCH_HEADERS := sgidefs.h