aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/musl
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-09-21 17:40:44 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-09-21 17:40:44 +0000
commit59130c59363e3855f2b2fc70da67fd76a5bcad93 (patch)
treee5ad2435643f14122fde1fb028fa19113f97cc21 /toolchain/musl
parenta8ae2027df886209df647e8e3a5919137b4bcaf7 (diff)
downloadmaster-187ad058-59130c59363e3855f2b2fc70da67fd76a5bcad93.tar.gz
master-187ad058-59130c59363e3855f2b2fc70da67fd76a5bcad93.tar.bz2
master-187ad058-59130c59363e3855f2b2fc70da67fd76a5bcad93.zip
musl: fix build on sh3
musl fails to build when compiled with gcc on sh3 (GCC target/#67260). Work it around. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47012 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/musl')
-rw-r--r--toolchain/musl/common.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/toolchain/musl/common.mk b/toolchain/musl/common.mk
index 82c15430a1..3045c634bc 100644
--- a/toolchain/musl/common.mk
+++ b/toolchain/musl/common.mk
@@ -23,6 +23,12 @@ HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/toolchain-build.mk
include $(INCLUDE_DIR)/hardening.mk
+# Please see https://gcc.gnu.org/bugzilla/show_bug.cgi?id=67260
+ifeq ($(CONFIG_sh3),y)
+TARGET_CFLAGS+= \
+ -fno-optimize-sibling-calls
+endif
+
MUSL_CONFIGURE:= \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \