aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/musl
diff options
context:
space:
mode:
authorMatteo Croce <matteo@openwrt.org>2015-06-25 10:14:22 +0000
committerMatteo Croce <matteo@openwrt.org>2015-06-25 10:14:22 +0000
commit3fc9fc7a53431eaadbb11f4bb80766553c2b72c9 (patch)
tree8f30b2afbdf020ab745eb8e2cac1c3b522d3f7a8 /toolchain/musl
parent672f31577df831aede9841d58fb61464d1ca5566 (diff)
downloadmaster-187ad058-3fc9fc7a53431eaadbb11f4bb80766553c2b72c9.tar.gz
master-187ad058-3fc9fc7a53431eaadbb11f4bb80766553c2b72c9.tar.bz2
master-187ad058-3fc9fc7a53431eaadbb11f4bb80766553c2b72c9.zip
fix mklibs with musl
crate a relative symlink to libc.so because make wildcard function ignores broken symlinks git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46123 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/musl')
-rw-r--r--toolchain/musl/patches/300-relative.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/toolchain/musl/patches/300-relative.patch b/toolchain/musl/patches/300-relative.patch
new file mode 100644
index 0000000000..dc7d167635
--- /dev/null
+++ b/toolchain/musl/patches/300-relative.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -180,7 +180,7 @@ $(DESTDIR)$(includedir)/%: include/%
+ $(INSTALL) -D -m 644 $< $@
+
+ $(DESTDIR)$(LDSO_PATHNAME): $(DESTDIR)$(libdir)/libc.so
+- $(INSTALL) -D -l $(libdir)/libc.so $@ || true
++ $(INSTALL) -D -l libc.so $@ || true
+
+ install-libs: $(ALL_LIBS:lib/%=$(DESTDIR)$(libdir)/%) $(if $(SHARED_LIBS),$(DESTDIR)$(LDSO_PATHNAME),)
+