aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/musl/patches/200-add_libssp_nonshared.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-07-24 15:35:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-07-24 15:35:55 +0000
commit16c32e7ce64e09c4a8ac37de45a67600e9db7f09 (patch)
tree2463a254f0c05d471bd491f5d949d96c9d042252 /toolchain/musl/patches/200-add_libssp_nonshared.patch
parent7d4eb63409e1a6dad56da2a12d207734afe014b1 (diff)
downloadmaster-187ad058-16c32e7ce64e09c4a8ac37de45a67600e9db7f09.tar.gz
master-187ad058-16c32e7ce64e09c4a8ac37de45a67600e9db7f09.tar.bz2
master-187ad058-16c32e7ce64e09c4a8ac37de45a67600e9db7f09.zip
musl: update to latest git version
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46481 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/musl/patches/200-add_libssp_nonshared.patch')
-rw-r--r--toolchain/musl/patches/200-add_libssp_nonshared.patch16
1 files changed, 4 insertions, 12 deletions
diff --git a/toolchain/musl/patches/200-add_libssp_nonshared.patch b/toolchain/musl/patches/200-add_libssp_nonshared.patch
index f696d4e537..ecdd2d2cb2 100644
--- a/toolchain/musl/patches/200-add_libssp_nonshared.patch
+++ b/toolchain/musl/patches/200-add_libssp_nonshared.patch
@@ -10,11 +10,9 @@ Signed-off-by: Steven Barth <steven@midlink.org>
2 files changed, 10 insertions(+), 2 deletions(-)
create mode 100644 libssp_nonshared/__stack_chk_fail_local.c
-diff --git a/Makefile b/Makefile
-index 2eb7b30..bfcabf7 100644
--- a/Makefile
+++ b/Makefile
-@@ -48,7 +48,7 @@ CRT_LIBS = lib/crt1.o lib/Scrt1.o lib/rcrt1.o lib/crti.o lib/crtn.o
+@@ -48,7 +48,7 @@ CRT_LIBS = lib/crt1.o lib/Scrt1.o lib/rc
STATIC_LIBS = lib/libc.a
SHARED_LIBS = lib/libc.so
TOOL_LIBS = lib/musl-gcc.specs
@@ -22,8 +20,8 @@ index 2eb7b30..bfcabf7 100644
+ALL_LIBS = $(CRT_LIBS) $(STATIC_LIBS) $(SHARED_LIBS) $(EMPTY_LIBS) $(TOOL_LIBS) lib/libssp_nonshared.a
ALL_TOOLS = tools/musl-gcc
- LDSO_PATHNAME = $(syslibdir)/ld-musl-$(ARCH)$(SUBARCH).so.1
-@@ -103,7 +103,8 @@ NOSSP_SRCS = $(wildcard crt/*.c) \
+ WRAPCC_GCC = gcc
+@@ -106,7 +106,8 @@ NOSSP_SRCS = $(wildcard crt/*.c) \
src/env/__libc_start_main.c src/env/__init_tls.c \
src/thread/__set_thread_area.c src/env/__stack_chk_fail.c \
src/string/memset.c src/string/memcpy.c \
@@ -33,7 +31,7 @@ index 2eb7b30..bfcabf7 100644
$(NOSSP_SRCS:%.c=%.o) $(NOSSP_SRCS:%.c=%.lo): CFLAGS += $(CFLAGS_NOSSP)
$(CRT_LIBS:lib/%=crt/%): CFLAGS += -DCRT
-@@ -144,6 +145,11 @@ lib/libc.a: $(OBJS)
+@@ -147,6 +148,11 @@ lib/libc.a: $(OBJS)
$(AR) rc $@ $(OBJS)
$(RANLIB) $@
@@ -45,14 +43,8 @@ index 2eb7b30..bfcabf7 100644
$(EMPTY_LIBS):
rm -f $@
$(AR) rc $@
-diff --git a/libssp_nonshared/__stack_chk_fail_local.c b/libssp_nonshared/__stack_chk_fail_local.c
-new file mode 100644
-index 0000000..2b403a6
--- /dev/null
+++ b/libssp_nonshared/__stack_chk_fail_local.c
@@ -0,0 +1,2 @@
+#include "atomic.h"
+void __attribute__((visibility ("hidden"))) __stack_chk_fail_local(void) { a_crash(); }
---
-2.1.4
-