aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/musl/headers
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-11-23 20:02:29 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-11-23 20:02:29 +0000
commit24cc4007ce46bb076bfe2879f66f19f52161f098 (patch)
treebc44c7e2aea0c387867ce3601e782b02a940d79e /toolchain/musl/headers
parentee048e8c321170b8eb9f06c65baa44d17b3455e1 (diff)
downloadmaster-187ad058-24cc4007ce46bb076bfe2879f66f19f52161f098.tar.gz
master-187ad058-24cc4007ce46bb076bfe2879f66f19f52161f098.tar.bz2
master-187ad058-24cc4007ce46bb076bfe2879f66f19f52161f098.zip
[buildroot] add preliminary support for musl
Musl is an alternative C-library, see http://www.musl-libc.org for more infos. Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34314 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/musl/headers')
-rw-r--r--toolchain/musl/headers/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/toolchain/musl/headers/Makefile b/toolchain/musl/headers/Makefile
new file mode 100644
index 0000000000..21e6b3bd15
--- /dev/null
+++ b/toolchain/musl/headers/Makefile
@@ -0,0 +1,16 @@
+PATH_PREFIX:=..
+
+include ../common.mk
+
+HOST_STAMP_BUILT:=$(HOST_BUILD_DIR)/.headers_built
+HOST_STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.uclibc_headers_installed
+
+define Host/Compile
+
+endef
+
+define Host/Install
+endef
+
+$(eval $(call HostBuild))
+